Tag Archives: IPv6

MikroTik IPv6 DNS RDNSS

MikroTik IPv6 DNS RDNSS

To activate on your MikroTik RouterOS device RDNSS, you must do the following.

Set the IPv6 DNS server.

/ip dns set server=2001:4860:4860::8888,2001:4860:4860::8844

Show the configuration

/ip dns print
servers: 2001:4860:4860::8888,2001:4860:4860::8844
dynamic-servers: 77.109.128.2,213.144.129.20
allow-remote-requests: no
max-udp-packet-size: 4096
query-server-timeout: 2s
query-total-timeout: 10s
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 9KiB

Enable RDNSS

/ipv6 nd set [f] advertise-dns=yes

Show the IPv6 nd configuration

/ipv6 nd print
Flags: X - disabled, I - invalid, * - default
0 * interface=all ra-interval=3m20s-10m ra-delay=3s mtu=unspecified reachable-time=unspecified retransmit-interval=unspecified ra-lifetime=30m hop-limit=unspecified advertise-mac-address=yes
advertise-dns=yes managed-address-configuration=no other-configuration=no

On Ubuntu/Debian linux distributions you can install rdnssd package which is capable of receiving advertised DNS address.

sudo apt-get install rdnssd

Links:

http://wiki.mikrotik.com/wiki/Manual:IPv6/ND

Multiple IPv6 addresses per interface Debian / Ubuntu

To set multiple IPv6 addresses on one interface in Linux, you can use the tool ip.

ip addr add first_ipv6_address dev eth1
ip addr add second_ipv6_address dev eth1

When you like to set this on the system boot, you must do this in /etc/network/interfaces

auto eth0
iface eth0 inet6 static
address first_ipv6_address Adress
netmask 128
gateway ipv6_gateway
up ip addr add second_ipv6_address/128 dev eth1
down ip addr del second_ipv6_address/128 dev eth1