Tag Archives: OS X

MikroTik IPv6 DNS RDNSS

MikroTik IPv6 DNS RDNSS

To activate on your MikroTik RouterOS device RDNSS, you must do the following.

Set the IPv6 DNS server.

/ip dns set server=2001:4860:4860::8888,2001:4860:4860::8844

Show the configuration

/ip dns print
servers: 2001:4860:4860::8888,2001:4860:4860::8844
dynamic-servers: 77.109.128.2,213.144.129.20
allow-remote-requests: no
max-udp-packet-size: 4096
query-server-timeout: 2s
query-total-timeout: 10s
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 9KiB

Enable RDNSS

/ipv6 nd set [f] advertise-dns=yes

Show the IPv6 nd configuration

/ipv6 nd print
Flags: X - disabled, I - invalid, * - default
0 * interface=all ra-interval=3m20s-10m ra-delay=3s mtu=unspecified reachable-time=unspecified retransmit-interval=unspecified ra-lifetime=30m hop-limit=unspecified advertise-mac-address=yes
advertise-dns=yes managed-address-configuration=no other-configuration=no

On Ubuntu/Debian linux distributions you can install rdnssd package which is capable of receiving advertised DNS address.

sudo apt-get install rdnssd

Links:

http://wiki.mikrotik.com/wiki/Manual:IPv6/ND

OS X dd status

OS X dd status
OS X
If you want to use dd and get the status information, you have to do this:

dd

dd if=./ubuntu-14.04.1lts-minimal-odroid-c1-20150131.img of=/dev/disk2

Status

watch killall -INFO dd

In the terminal where dd is running, you get the status.

dd if=./ubuntu-14.04.1lts-minimal-odroid-c1-20150131.img of=/dev/disk2 bs=4m
6+0 records in
5+0 records out
20971520 bytes transferred in 9.587478 secs (2187387 bytes/sec)
7+0 records in
6+0 records out
25165824 bytes transferred in 12.823707 secs (1962445 bytes/sec)

Mac screenshot shortcut

Mac screenshot shortcut

 

If you like to create a screenshot under OS X, you must press the following shortcuts.

 

Screen

Cmd + Shift + 3 / Save the screen in one file
Cmd + Ctrl + Shift + 3 / Save the screen to the clipboard.

Area

Cmd + Shift + 4 / Save a selected area in a file.
Cmd + Ctrl + Shift + 4 / Save a selected area to the clipboard.

Window

Cmd + Shift + 4, space bar / Save a selected element/window in a file.
Cmd + Ctrl + Shift + 4, space bar / Save a selected element/window to the clipboard.